2015年9月8日,Joomla CMS 官方发布了 Joomla CMS 核心 3.4.4 稳定版本。这是 Joomla 3.x 系列一个修补版本,解决了一个轻度安全问题。强烈建议所有的 Joomla 用户将网站核心立即升级到这个版本。

Joomla 3.4.4 released
Joomla 3.4.4 released

Joomla 3.4.4 的新功能

Joomla 3.4.4 除了封堵安全漏洞,也有几项新功能/改进:

  • 进一步清理 en-GB 语言;
  • 修复了 MSSQL 和 PostgresSQL 数据库上安装 Joomla 的问题;
  • 更新了 jQuery, HTML5Shiv 及 CodeMirror ;
  • 完成了对 Joomla 代码样式规则的部署;

在开发过程中,有36名程序员提交了超过500次代码,解决了多大245个问题,详情见 Github 上面的完整列表

修复的安全漏洞

Joomla 3.4.4 修复了一个安全漏洞:低优先度 - 核心 - XSS 弱点。详情见官方文章

如何升级到 Joomla 3.4.4

首先请确认你的服务器能支持 Joomla 3.4.4 的运行,例如,PHP 版本最好在 5.4.0 以上。

然后,在升级之前必须做的一个重要工作就是:对现有网站进行完整的全站备份,并且测试备份包可以顺利还原网站。

  • 如果你正在运行 Joomla 3.x 低版本,可通过网站后台的“组件 -> Joomla 更新”菜单链接进行在线自动升级;如果在线升级有困难,也可以 下载并安装 Joomla 3.4.4 升级包 进行手工升级。
  • 如果你正在运行 Joomla 2.5.x  甚至 Joomla 1.5.x,那么,这个升级过程不那么容易。你的现有 Joomla 核心版本越低,网站上安装的第三方扩展数量越多,则升级到最新 Joomla 核心的难度就越高。建议利用网站的副本在测试服务器上进行升级尝试。如果自己无法完成网站升级,可以与 Joomla 之门 联系,我们提供收费的网站核心升级服务。

 

{quickdown:1379}