登录 注册

登录

问题 利用XAMPP安装Joomla后台成功启动但【前台报错】

更多
2009年09月17日 16:56 #1 作者: 1986jade
现在前台有一段warning的提示:
Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in D:\Program Files\xampp\xampp\htdocs\Joomla\libraries\joomla\cache\handler\callback.php on line 99
附件是前台登录的错误显示。
小鸟第一次安装,  ???

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年09月18日 09:03 #2 作者: 1986jade
问题已经解决了~~~。估计是软件版本的问题。
后来我用本站,老白提供的joomla以及xampp就成功搭建完成~~~~。 ;D

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年09月30日 10:32 #3 作者: whailin
天哪,这问题我也碰到了。

我是用的最新版的joomla 和 XAMPP1.7.2+Joomla_1.5.14-Stable-Full_Package

在英文XP笔记本上也报这个错,后台确能进,也能显示文章,就是菜单出问题。

但是同样的joomla版本我装在dedecms的集成包环境下就一点问题没有呀,我看是不是这个破XAMPP的问题,因为我看国外的英文教程用的安装包是不用在黑窗口下选东西的,而这个最新的XAMPP确实装完后,弹出个黑窗口问这问那的让你选。

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年09月30日 16:28 #4 作者: Joomla之门
whailin 的问题在于:你使用了最新的 XAMPP 1.7.2 版本,而该版本中 PHP 是 5.30,而 PHP 5.30 运行 Joomla 1.5.14 就出问题!

你有两条路可选:

1、放弃 XAMPP 1.7.2,安装本站提供的 XAMPP 1.7.0 (PHP 5.2.9);

2、放弃 Joomla 1.5.14,安装 Joomla! 1.5.15 RC 版本。

其实,关于 PHP 5.30 与 Joomla! 1.5.14- 版本之间冲突的问题,我们在论坛已经讨论过了,还发了电子报提醒会员。当时 whailin 还没加入本站,所以就不知道这个情况。

顺便提醒一下 whailin: 本站下载栏目不支持迅雷、快车等下载工具,再大的文件也只能用浏览器自带的下载功能来下载(这是下载系统软件自身的问题,并非人为设置,请谅解)。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年10月01日 12:49 #5 作者: whailin
谢谢老白的回复,我已经惹不起躲得起了,先行换了你们的1.7.0的XAMPP,我只要能顺利工作下去就行,具体是啥问题,真是不想多研究了:)
下载的东西有的就能用迅雷下,这又是为什么?

登录 或者   注册一个会员帐号 来参与讨论