登录 注册

登录

问题 SQL=错误

更多
2016年05月15日 23:52 #1 作者: RayW
RayW 创建了话题: SQL=错误
白站,昨天在VPS上用akeeba 恢复网站备份,在进入到最后一步设置的时候,出现错误提示 sql=
然后就进行不下去了,请问是哪里的设置需要修改?

登录 或者   注册一个会员帐号 来参与讨论

更多
2016年05月15日 23:59 #2 作者: Joomla之门
Joomla之门 回复了话题: SQL=错误
单纯看到这么一句不好推测原因。

你可以参考一下网站的 log 日志: /var/log/httpd/domains/xxx.com.error.log

把域名替换成你自己的。看看 log 文件里面是否记录了什么错误?

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2016年05月16日 10:02 - 2016年05月16日 10:11 #3 作者: RayW
RayW 回复了话题: SQL=错误
白站,错误日志已经发到旺旺,麻烦请给看下
日志的前面部分是之前几次操作的记录,按最新的记录,有一行描述里提到 错误,
我想这个应该是原因
public_html/installation/framework/database/driver/mysqli.php on line 597

我下载了mysqli.php 文件,但是真个文件只有430行,根本没有597这一行
最后修改: 2016年05月16日 10:11 由 RayW.

登录 或者   注册一个会员帐号 来参与讨论

更多
2016年05月16日 20:27 #4 作者: Joomla之门
Joomla之门 回复了话题: SQL=错误
installation 目录是 Joomla 核心安装过程中使用的目录,安装结束之后就删除了,所以跟这个目录基本上没关系。

既然出错提示有 SQL 字样,我们就需要同时检查一下 mysql 的日志( /var/log/mariadb/mariadb.log ).

有空我们在旺旺上详谈,一起研究一下这个问题。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2016年05月17日 12:08 #5 作者: RayW
RayW 回复了话题: SQL=错误
在多次重新尝试后,
目前的已经搞定网站的恢复。
我的估计是和php版本有关系。
第一个备份是基于5.5.30进行备份的,但是在vestacp使用默认设置及5.4.
就出现SQL的错误提示以及500的错误。
想问下白站,基于不同的php,备份是不是不能向上向下兼容?
如果可以,是不是vesta cp虽然有不同PHP选项,但是生效有问题?

后来我重新在php7.0.5环境下重新备份,然后在vesta CP 里选定php70,再重新进行恢复操作。
目前已经恢复正常,网站可以正常访问,不过用了安全插件,后台需要重置下。

vesta cp 在添加站点的时候,可以同时设置ftp账号,但是php版本只能在添加网站后再选择修改,这时候才能选择php版本。所以要额外一步才能进行选择php版本。

登录 或者   注册一个会员帐号 来参与讨论

更多
2016年05月18日 09:06 #6 作者: Joomla之门
Joomla之门 回复了话题: SQL=错误
我最近在使用 “vestacp 多版本 PHP 模板” 这个功能的时候,也发生了一些小问题,尽管不太严重,但总是觉得不太顺利。

考虑到这个功能也是 0.23 版本,看起来也是刚刚起步,所以给作者一些时间继续完善完善。

我觉得这个责任应该由 CentOS 官方来承担,明明知道全世界那么多服务器都用 CentOS 作为操作系统,为什么不主动给 CentOS “内置”一个多版本 PHP 自由选择功能?为什么不最高支持到最新的 PHP7?竟然默认只提供 PHP 5.4.45,真是太傲慢了!

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论