登录 注册

登录

问题 在xampp下安装joomla后报出warning~~

  • pantimmy110
  • 话题作者
  • 访客
  • 访客
2009年08月06日 13:36 - 2009年08月06日 13:42 #1 作者: pantimmy110
pantimmy110 创建了话题: 在xampp下安装joomla后报出warning~~
我在XAMPP环境下安装joomla,安装好后在“完成”页面显示了两行代码:
Deprecated: Assigning the return value of new by reference is deprecated in C:\xampp\htdocs\joomla\libraries\pattemplate\patTemplate.php on line 1424

Deprecated: Assigning the return value of new by reference is deprecated in C:\xampp\htdocs\joomla\libraries\pattemplate\patErrorManager.php on line 202
不知道对joomla有没有影响 ,是因为什么造成的呢?
进入后台后再模块管理部分也报出了warning:
Warning: Parameter 1 to JHTMLGrid::access() expected to be a reference, value given in C:\xampp\htdocs\joomla\libraries\joomla\html\html.php on line 87

Warning: Parameter 1 to JHTMLGrid::checkedOut() expected to be a reference, value given in C:\xampp\htdocs\joomla\libraries\joomla\html\html.php on line 87

Warning: Parameter 1 to JHTMLGrid::published() expected to be a reference, value given in C:\xampp\htdocs\joomla\libraries\joomla\html\html.php on line 87
不知道是什么意思了...望高手指出~~
我的joomla是解压在C:\xampp\htdocs\joomla\下安装的。

另外刚才看了下,在菜单项目管理下也有warning:
Warning: Parameter 4 to JHTMLMenu::treerecurse() expected to be a reference, value given in C:\xampp\htdocs\joomla\libraries\joomla\html\html.php on line 87

Warning: array_slice() expects parameter 1 to be array, null given in C:\xampp\htdocs\joomla\administrator\components\com_menus\models\list.php on line 143

Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\joomla\administrator\components\com_menus\models\list.php on line 147

Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\joomla\administrator\components\com_menus\views\list\view.php on line 65

Warning: Invalid argument supplied for foreach() in
C:\xampp\htdocs\joomla\administrator\components\com_menus\views\list\tmpl\default.php on line 69

最后修改: 2009年08月06日 13:42 由 .

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年08月07日 08:45 #2 作者: forgottenp
http://www.joomlagate.com/content/view/153/29/

自己去看看他说有问题的那个PHP文件那行程序所指向的东西是不是缺了吧

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年08月12日 14:23 #3 作者: ziyang
我也是出现这样的问题,请高手帮助解决

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年09月30日 09:30 #4 作者: whailin
我今天在安装时也出现同样问题
Deprecated: Assigning the return value of new by reference is deprecated in C:\xampp\htdocs\eb5\libraries\pattemplate\patTemplate.php on line 1424

Deprecated: Assigning the return value of new by reference is deprecated in C:\xampp\htdocs\eb5\libraries\pattemplate\patErrorManager.php on line 202

请各位高手来给指点一下吧

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年09月30日 10:26 #5 作者: ivanmarkliu
我用XAMPP 1.7.0 PHP版本PHP: 5.2.8没问题。如果你用的是PHP 5.3的话建议你换个XAMPP的版本。

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年09月30日 12:22 #6 作者: whailin
我更换了本站的XAMPP1.7.0版的,确实全部的毛病都没了。
谢谢ivanmark

登录 或者   注册一个会员帐号 来参与讨论