登录 注册

登录

问题 请问一下白老大,我能不能修改一下这个默认值呢?

更多
2008年02月05日 23:54 #1 作者: 寒风彻骨
我安装了白老大汉化的joomla1.5正式版,用起来没问题,就是每次提交文章的时候,在文章参数一栏里面,文章的到期日期总是一个默认的当时8:00,而我安装原来的joomla就没有这个问题,每次添加文章就要修改一下这个参数,一不留神就忘了,请问这个参数的默认值应该在哪里修改呢

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年02月06日 07:22 #2 作者: Joomla之门
在 Joomla! 1.0.x 平台,我记得发表文章时创建时间就是当时你开始撰写的真实时间;在 Joomla! 1.5 理应也是如此。

刚才我看了看我测试用的 Joomla! 1.5,点击“创建文章”之后,右侧“文章参数”中的创建时间就自动选择了当前时间。

如果你总是看到 8:00 这个时间,是否说明你总是在8点整开始撰写文章?或者,你总是在其他某个固定时间开始撰写,而由于你没有设置好“时区”,所以显示为8点?

建议进入 Joomla! 1.5 后台的“全局设置”,检查一下“服务器”这个标签页面上的时区是否选择了“北京”所在时区(UTC +08:00)?

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年02月06日 13:08 #3 作者: 寒风彻骨
老大误会了,我指的不是创建时间,我指的是发布结束的时间,每次总是8:00,时间的设置也正常,而我以前用joomla的时候,发布结束的时间是“从不”

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年02月07日 08:15 #4 作者: Joomla之门
抱歉,上次理解错了!

刚才我又看了一下我自己安装的 Joomla! 1.5,发现创建文章时,结束发布时间默认是“永不”。

所以就不明白为何你那里总是 8:00 ?

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年02月08日 17:41 #5 作者: 忧伤b小调
哈哈,他也就是不明白为什么会有8:00才问你的....

我刚才也看了一下,我那边默认的也是“永不”

后台好象没有办法修改,

自己找找PHP相关文件修改吧

真实打造华人最大暗黑艺术网站: www.cnhell.com 采用joomla! 2.5 搭建

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年02月09日 13:47 #6 作者: 寒风彻骨
找到了一个不算方法的方法,那就是登录后台用英文界面,这个问题就不存在。。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月25日 18:42 #7 作者: mymoola
开始发布:2008-08-25 10:38:46
发布结束:2008-08-25 00:00:00

还没发布就结束了,这个每次要修改,有没有设定为 永不 的方法吗? 你们都这样吗? 真郁闷了。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年10月17日 12:02 #8 作者: a624762500
在贵站下载的中文完整版有一个bug, 在1.55的版本就有一个问题,到1.57的还是有, 就是写文章时必须手动改发布结束时间,要不然发表的文章全是到期

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年10月17日 16:37 #9 作者: Joomla之门
我把有关文章结束发布日期的几个帖子都合并到一起了。说实话,我多次测试都没有发现有什么问题 —— 我一直 用 XAMPP 做 Joomla! 本地测试服务器

或许是服务器的原因吧。因为楼上有人说后台语言界面改用英文就好了,这或许是因为“永不”在英文里面的“never”能够被服务器正确理解。

既然这样,我下次发布 1.6 版本时就将“永不”改用 never 吧,希望能解决问题。你们也可以尝试手动修改,要修改的文件是:/administrator/language/zh-CN/zh-CN.com_content.ini 第 96 行。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年10月17日 18:00 #10 作者: a624762500
好了,我把永不两个字重新用我的输入法打一次保存就没事了, 谢谢

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年12月09日 21:24 #11 作者: dada
我也遇到同样的问题,请问你改的是什么地方的永不啊,是后台新文章,还是修改文章,还是/zh-CN.com_content.ini 第 96 行,还是数据库啊,我有很多文章出这个问题

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年08月19日 15:38 #12 作者: shrine
谢谢,遇到同样问题。同样方法解决。

提示楼上的dada同学,

zh-CN.content.ini是在管理员目录下:
/administrator/language/zh-CN/zh-CN.com_content.ini

水浒名言:不要焦躁……

登录 或者   注册一个会员帐号 来参与讨论