登录 注册

登录

问题 FrontPage SlideShow 幻灯式图文展示组件 乱码问题.

更多
2008年11月17日 09:26 #1 作者: 忧伤b小调
FrontPage SlideShow 幻灯式图文展示组件很不错.

老白刚公布下载,我就第一时间下载安装测试,在本地安装测试发现一些正常.可是在服务器端上运行,此组件的“幻灯片名称”和“自定义字段”就出现了乱码现象.

2服务器参数对比如下:
没出现乱码的(本地服务器):
服务器信息:  Windows NT JUJUMAO 5.1 build 2600 
数据库版本:  5.0.51b-community 
数据库整理规则(DATABASE COLLATION):  utf8_general_ci 
PHP版本:  5.2.6 
网站服务器:  Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 
使用PHP接口的网站服务器:  apache2handler 
Joomla!版本:  Joomla! 1.5.7 Production/Stable [ Wovusani ] 9-September-2008 23:00 GMT 

出现乱码的(远程服务器):
  • 服务器信息:  Linux server081107.paangood.net 2.6.18-92.el5 #1 SMP Tue Jun 10 18:49:47 EDT 2008 i686
    数据库版本: 5.0.67-community
    数据库整理规则(DATABASE COLLATION): utf8_general_ci
    PHP版本: 5.2.6
    网站服务器: Apache/1.3.41 (Unix) mod_perl/1.30 mod_ssl/2.8.31 OpenSSL/0.9.8b
    使用PHP接口的网站服务器: cgi-fcgi
    Joomla!版本: Joomla! 1.5.7 Production/Stable [ Wovusani ] 9-September-2008 23:00 GMT
截图如下:


真实打造华人最大暗黑艺术网站: www.cnhell.com 采用joomla! 2.5 搭建

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年11月17日 09:28 #2 作者: 忧伤b小调
是跟网站服务器有直接关系吗?

高手赐教.

能得到你们的帮助,万分感谢.

真实打造华人最大暗黑艺术网站: www.cnhell.com 采用joomla! 2.5 搭建

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年11月17日 10:15 #3 作者: Joomla之门
这个与语言文件应该没有关系。从图上看,出现乱码的地方都是幻灯名称。这就提示该组件(在某些环境)不能完美支持中文幻灯名称。

解决办法:请使用英文作为幻灯名称,反正这个名称只是后台标识用,前台几乎不用显示。英文菜的可以用拼音。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年11月17日 13:36 #4 作者: 忧伤b小调
这乱码不只是名称是乱码而且在“自定义文字 (将替代已有的文章引言部分)"里的内容也是乱码,看来必须全部都使用英文了...

真实打造华人最大暗黑艺术网站: www.cnhell.com 采用joomla! 2.5 搭建

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年03月26日 08:41 #5 作者: wangheng
我的也是,我的在获取单元列表时没有乱码 当选择单元列表后 出来的分类列表和文章列表都是乱码

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年04月05日 06:16 #6 作者: wbbwb
我试过了,也存在这种情况。所以,我现在幻灯演示用的com_morfeoshow_1.1.0.zip。后台的图片文件用英文名称,说明用中文。

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年05月26日 23:46 - 2009年05月27日 09:39 #7 作者: 萧静毓
本地计算机上测试过程中,在Joomla1.5.7版本上安装Frontpage_SlideShow_v2_Chinese_Pack_VIP,自定义文本里的中文显示正常,但是升级到本站的Joomla 1.5.10后,再安装FrontPage slideshow,所有的自定义文本里的中文在保存后都显示为问号,请高手帮忙看看,这是怎么回事?
最后修改: 2009年05月27日 09:39 由 czp568.

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年04月24日 16:54 #8 作者: tindson
安装了本站的FrontPage SlideShow的语言包,其他功能都正常,只是标题和自定义内容一旦设置成中文效果就显示为“??”,谁知道解决办法吗。

登录 或者   注册一个会员帐号 来参与讨论

更多
2011年02月27日 17:48 #9 作者: matteowang
大家好,
这几天在做一个新站,反复测试和调试。 我安装了Frontpage SlideShow 后出现了一个问题。创建新的幻灯条目时,条目的名称,详细介绍等等用中文输入,保存后,所有的中文文字都变成了问号,英文字符都是好的,不知道为什么啊?以前安装都没有这样的问题的。希望有经验的大哥指教一下,小弟先谢谢了

登录 或者   注册一个会员帐号 来参与讨论