登录 注册

登录

问题 白大侠,PhotoSlide GK2和jquery1.3.2有冲突,没办法共用!(自己已解决)

更多
2009年12月04日 11:15 - 2009年12月04日 14:22 #1 作者: megcker
PhotoSlide GK2和jquery1.3.2竟然不能公用,晕死!我暂时还没有发现比这个更好的幻灯片插件!
有其他的推荐么?就是能支持网站的多地方的幻灯片,比如:首页有,频道页有,但是他们的图片是不同的!

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年12月04日 11:38 #2 作者: windcutstorm
我想用PhotoSlide GK3,不过一直是加载,显示不了图片
可能是不会用
暂用Ozio_Gallery,展示图片不错,不过文字就不是那么方便了
可以多处引用

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年12月04日 13:12 #3 作者: megcker
真的么?是哦!我去看看你推荐的看看!

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年12月04日 13:34 #4 作者: megcker

登录 或者   注册一个会员帐号 来参与讨论

更多
2009年12月04日 14:21 - 2009年12月04日 15:28 #5 作者: megcker
呵呵,寻寻觅觅,总算找到了解决的方案!!!
原来最后找出来的原因是:
Firstly I suggest to disable third party modules and extensions which are using jQuery framework on your site - it can causes conflicts with mootools used in our modules.

是jquery和mootools 的冲突造成的!加入如下代码,顺利解决!

<script type="text/javascript"> 
$(function() { 
var sss=jQuery.noConflict(true); 
}); 
</script>

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年01月24日 02:16 #6 作者: musicpig
如何加上以上代码,加在哪呢?我用的photoslide 3也遇上同样的问题。

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年01月24日 03:10 #7 作者: musicpig
在此贴中得到启示,http://www.joomlagate.com/component/option,com_smf/Itemid,31/topic,3212.msg24479/
把代码加到head前,

但photoslide3 还是不能正常显示。

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年01月25日 11:01 #8 作者: mymyhope
Gavikpro的模板,扩展的浏览器兼容性,js的兼容性都是不太好的,而且缺少说明文档,其实比他好的slideshow扩展还是非常多的。

www.cn21cn.com
Magento中文网站
www.magentochina.org
QQ:703640

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年01月25日 18:43 #9 作者: musicpig

登录 或者   注册一个会员帐号 来参与讨论