登录 注册

登录

问题 大家好,想问个AllVideos Reloaded的问题

更多
2010年03月08日 17:34 #1 作者: matteowang
最近网站搬家了,换了VPS服务器, 但发现网站中所有的YOUTUBE视频都不能播放了。(本人不在国内)不知道是换了服务器的问题还是 AllVideos Reloaded 出了问题,想先问问各位大哥,谢谢!!!

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月08日 17:50 #2 作者: Joomla之门
能否把展示 Youtube 视频的那段代码贴出来?(注意使用 code 标记)

或者把出问题的网页 URL 贴出来,这样才好诊断。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月08日 17:51 #3 作者: musicpig
换服务器没改视频链接就不会出现问题的,你发邮件问问vps的管理员,一般托管服务商都会很快给你回复的。

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月08日 17:52 - 2010年03月09日 17:37 #4 作者: matteowang
大家可以看看这个页面,里面有个YOUTUBE的视频但不能播放了

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月08日 18:38 #5 作者: matteowang
我发现问题了,但不知道怎么解决
如果我用的 {youtubejw} {/youtubejw} 这个标签的话,视频就不显示了,但如果用{youtube} {/youtube} 这个标签视频是可以显示的,但两者的区别是,前者点击视频,视频就停止了,后者点击视频就跳到YOUTUBE的网站上去了,我想要的是不会跳掉YOUTUBE网站的,这样就不会把流量带走了,但不知道怎么改,希望大家帮帮忙,看看

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月09日 14:08 #6 作者: forgottenp
你以前用youtubejw的标签能播放么,怎么我看jw_allvideos_sources.php文件,只有定义youtube标签的。。。。

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月09日 15:19 #7 作者: Janet
我原本用{youtubejw} {/youtubejw}一切都没问题,但是奇怪最近居然按play,视讯都不动.不知道怎么解决???

后来我改用{youtube} {/youtube}就可以了.但是我不想用{youtube} {/youtube},因为在视讯完后,都会出现
youtube的其它影片.

假如是用{youtubejw} {/youtubejw},在结束后,窗口会回到原来的影像上.

后来我又试了将影片放在[本地媒体],影片是可以正常播放.但是一开始还没按play之前,视讯是黑色的.没有影像在上面.
我也有试了将一张1.jpg与1.mp4放在同的样/videos下,但是也是一样,没办法视讯一开始还是留在黑色的窗口????

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月09日 15:21 #8 作者: Janet
我原本用{youtubejw} {/youtubejw}一切都没问题,但是奇怪最近居然按play,视讯都不动.不知道怎么解决
后来我改用{youtube} {/youtube}就可以了.但是我不想用{youtube} {/youtube},
因为在视讯完后,都会出现youtube的其它影片.假如是用{youtubejw} {/youtubejw},在结束后,窗口会回到原来的影像上.
后来我又试了将影片放在[本地媒体],影片是可以正常播放.但是一开始还没按play之前,视讯是黑色的.没有影像在上面.
我也有试了将一张1.jpg与1.mp4放在同的样/videos下,但是也是一样,没办法视讯一开始还是留在黑色的窗口????

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月09日 15:23 #9 作者: Janet
对不起,由于符号弄错,所以后面的说明没连法显示,现在更正.

我原本用{youtubejw} {/youtubejw}一切都没问题,但是奇怪最近居然按play,视讯都不动.不知道怎么解决
后来我改用{youtube} {/youtube}就可以了.但是我不想用{youtube} {/youtube},
因为在视讯完后,都会出现youtube的其它影片.假如是用{youtubejw} {/youtubejw},在结束后,窗口会回到原来的影像上.
后来我又试了将影片放在本地媒体,影片是可以正常播放.但是一开始还没按play之前,视讯是黑色的.没有影像在上面.
我也有试了将一张1.jpg与1.mp4放在同的样/videos下,但是也是一样,没办法视讯一开始还是留在黑色的窗口????

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年03月09日 17:40 #10 作者: matteowang
我也是,可能是youtube 吧视频的播放方式修改了,造成 原本用{youtubejw} {/youtubejw}不能播放了,希望白哥可以帮忙看看,修改一下,在回复{youtubejw} {/youtubejw}的使用,谢谢!!!

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年06月13日 18:19 #11 作者: matteowang
问题解决了,看了一篇老外的文章,他们是怎么做的
先到  www.longtailvideo.com/players/jw-flv-player/ 下载一个免费包
打开后在里面可以找到 player.swf 这个文件, 把它改为 mediaplayer.swf 用FTP 上传到  plugins\content\avreloaded 覆盖里面原来的 mediaplayer.swf
在上传 yt.swf  到相应的目录里,就一切OK了,
  现在就可以用 {youtubejw} {/youtubejw}

老外的帖子地址
joomlacode.org/gf/project/allvideos15/forum/?action=ForumBrowse&forum_id=7580&_forum_action=ForumMessageBrowse&thread_id=16861

登录 或者   注册一个会员帐号 来参与讨论