登录 注册

登录

问题 Joomla! 1.0.13 简体中文版(UTF-8)前后台乱码

更多
2007年11月26日 11:14 #1 作者: ly5437
环境:xampp-win32-1.6.4
Joomla: Joomla! 1.0.13 简体中文版(UTF-8)
安装后,前后台乱码。
查看了MySql数据库,数据显示为????,都是组件内容乱码。

具体情况看图

登录 或者   注册一个会员帐号 来参与讨论

更多
2007年11月26日 11:43 #2 作者: Joomla之门
呵呵,我也是在 xampp-win32-1.6.4 上面安装本站的Joomla! 1.0.13 简体中文版 ,那么我们应该很容易对比的。

你在安装之前,有没有手动创建数据库?创建时必须将 phpMyAdmin 界面上“整理”一栏选择为 utf8_unicode_ci (就是下拉选单的最后一个)。

刚才顺便去数据库看了一下,里面的中文是正常显示的(附图)。

你是否安装时选择了自动创建数据库?那么这样可能会将数据库的字符编码设置错误。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2007年11月26日 11:59 #3 作者: ly5437
刚重新安装,显示正常了,是自动创建数据库产生的乱码。

多谢老白。

登录 或者   注册一个会员帐号 来参与讨论

更多
2007年11月26日 15:32 #4 作者: killermyth
还想提问了,两次都没有体会到
呵呵,第三次装解决了,谢谢

登录 或者   注册一个会员帐号 来参与讨论

更多
2007年12月18日 23:58 #5 作者: silvia22
你在安装之前,有没有手动创建数据库?创建时必须将 phpMyAdmin 界面上“整理”一栏选择为 utf8_unicode_ci (就是下拉选单的最后一个)。?

请问这个Phpmyadmin在哪里啊?汗,我装了两次都是同样结果

登录 或者   注册一个会员帐号 来参与讨论

更多
2007年12月19日 01:52 #6 作者: silvia22
进了phpmyadmin改了utf8_unicode_ci ,重装了,还是老样子

登录 或者   注册一个会员帐号 来参与讨论

更多
2007年12月19日 03:04 #7 作者: silvia22
最后安装了1.0.11的版本,终于乱码消失。。。

登录 或者   注册一个会员帐号 来参与讨论

更多
2007年12月19日 07:36 #8 作者: Joomla之门
在 XAMPP 中访问 phpmyadmin 的URL 是:http://localhost/phpmyadmin

我还没有认真比较过 Joomla! 1.0.11 与 1.0.13 版本的差别,或许是汉化还不够到位。不过我在 XAMPP 上面安装多次都没有乱码(我的操作系统是 windows XP 中文版)。

欢迎继续反馈,我再继续改进汉化版本。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2007年12月22日 22:33 #9 作者: flyfoxs
白建鹏,你好
我看了你其它的帖子,你已经找到了在Linux平台下无法正常显示中文的原因,不知道可有修改好这个Bug之后的新版本发布?

登录 或者   注册一个会员帐号 来参与讨论

更多