登录 注册

登录

问题 请教关于针对ie6浏览器设定某些模块是否显示的办法

更多
2013年03月10日 10:15 - 2013年03月10日 11:10 #1 作者: jamesyan
请教白站长,我想针对ie6浏览器设定某些模块是否显示,是否有办法呢。

尝试不同浏览器设定不同模板的,用了Browser assign template for J1.6 ,没有成功,估计我是j2.5的原因吧。

最好还是设定模块是否显示,这样实施起来比较简单一些。

麻烦您啦,谢谢。
最后修改: 2013年03月10日 11:10 由 jamesyan.

登录 或者   注册一个会员帐号 来参与讨论

更多
更多
2013年03月10日 20:32 #3 作者: jamesyan
我对编程不懂得,这个方法对我来说有些难了,不知是不是有其它简单的方法呢,比如插件、组件等方法。

再次感谢您的帮助。

登录 或者   注册一个会员帐号 来参与讨论

更多
2013年03月10日 21:53 #4 作者: Joomla之门
那就用 Advanced Module Manager 高级模块管理器 吧,它可以允许你设定针对某个浏览器隐藏或者显示指定的模块。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2013年03月11日 08:39 #5 作者: jamesyan
实在太感谢了,安装试一下,希望能够成功。

发现这个组件现有版本需要php5.3+,是否有老一些的版本支持php5.2的呢?

登录 或者   注册一个会员帐号 来参与讨论

更多
2013年03月11日 13:06 #6 作者: Joomla之门
不建议使用旧版本,旧版本要么功能不丰富,要么存在安全漏洞。

最好的办法就是督促你的主机商尽快升级 PHP 版本到 5.3.1 以上。否则你可以考虑换主机了。实际上 PHP 5.2 已经很老了,可恨国内很多主机商竟然甚至还在用 PHP 4.x 在骗人。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2013年03月11日 15:39 #7 作者: jamesyan
实在太悲催了,刚试了php5.3,customlist4sobipro模块竟然排序出错。

只能在php5.2的基础上想办法了,如果白站长有老版本的资料,还请帮助我呢。

谢谢。

登录 或者   注册一个会员帐号 来参与讨论

更多
2013年03月11日 19:20 #8 作者: Joomla之门
我个人认为,使用 PHP 5.3 是大势所趋。你应该要求那个模块的作者提供对 PHP 5.3 的支持,而不是降低 PHP 版本。

当然了,你既然有这个想法,我也能帮你找到支持 PHP 5.2 的版本:

Advanced Module Manager v3.1.3 是最后一个支持 PHP 5.2 的版本,此后的版本都要求 PHP 5.3 。

再次声明一点:如果你安装了旧版本,将来发生了任何问题,都不要埋怨我。我已经说过了不赞成使用旧版本。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论