登录 注册

登录

已解决 joomla3.4.4安装Artio JoomSEF v4.6.2出错,求解决方法

更多
2015年10月21日 10:23 - 2015年10月21日 11:04 #1 作者: e.o.m
正常通过扩展上传.zip文件安装,突然就出现了下面的提示,然后网站前台后台都无法登陆了。

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at 这个 E-mail 受反垃圾邮件程序保护,您需要启用 JavaScript 才能查看。 to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80

最后修改: 2015年10月21日 11:04 由 Joomla之门. 原因: 添加引用标记

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月21日 20:37 #2 作者: Joomla之门
Artio JoomSEF 在安装过程中会检查网站根目录下是否存在 .htaccess 这个文件,如果不存在就自动创建。或许,你网站根目录下之前没有这个文件,而 Artio JoomSEF 自动创建的那个文件又不符合你服务器的配置参数,所以导致了无法登录?

建议检查一下网站根目录的文件,如果发现原来没有 .htaccess 而现在有了,请将该文件改名 (例如改为 htaccess.new )使其失效,然后尝试登录网站。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月21日 21:24 #3 作者: e.o.m
我通过暂时删除configuration.php文件,在页面有错误的情况下强行登陆后台,提示缺少configuration.php文件时重新放回,刷新页面后进入后台,删除安装出错的Artio JoomSEF,然后用Akeeba Backup备份整站,删除旧站重新恢复备份后,网站前后台即回到未安装Artio JoomSEF前的正常情况(没有错误),网站是恢复了,但我还是想知道正常情况下Artio JoomSEF需要进行怎么样的准备或者条件下才能安装成功并且可以使用呢,还麻烦白老师具体的说明下安装过程需要设置或者注意的地方。(另:使用的joomla版本为从官网下载的Joomla_3.4.4-Stable-Full_Package)

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月22日 09:19 #4 作者: Joomla之门
我刚刚在 Joomla 3.4.4 上面安装了 Artio JoomSEF v4.6.3 中文版 ,一切顺利。

建议你在安装之前,先检查一下你的 Joomla 后台“全局设置”里面,把“搜索引擎优化”这里的所有选项都关闭(禁用)。然后再开始安装。

JoomSEF 最新版本是 4.6.3,我刚刚已经更新汉化版,请下载新版本来安装。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月23日 19:41 #5 作者: e.o.m
刚刚安装全新的joomla 3.4.4,然后安装中文语言包,换成中文,接着把 后台“全局设置”里面,SEO Settings的Search Engine Friendly URLs,Use URL Rewriting,Adds Suffix to URL,Unicode Aliases,Include Site Name in Page Titles都设置成NO,然后到EXTENSIONS里进行joomsef的安装,结果还是出现上面1楼的错误提示,joomsef 4.6.2或者4.6.3试了都一样,人品有问题了,>.<

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月24日 09:30 #6 作者: e.o.m
白老师,您能把您用的joomla3.4.4和joomsef 4.6.3发一份到我邮箱里吗?我用您的再安装试试(shingshing@163.com)

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月25日 14:39 #7 作者: e.o.m
为什么我安装上就出错呢,版本,SEO等都关闭了,真不明白是哪出错

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月25日 20:39 #8 作者: Joomla之门
我估计跟你的服务器配置有关系。如果方便,请通过 email 或者淘宝旺旺提供你网站的管理员账号,我来帮你操作试试看。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月26日 08:22 #9 作者: e.o.m
服务器方面我就是在WIN7 64位本机上安装了wampserver2.5-Apache-2.4.9-Mysql-5.6.17-php5.5.12-64b来使用,配置默认不变,只开了apache的模块“rewrite_moudel”

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月26日 10:01 - 2015年10月26日 10:02 #10 作者: Joomla之门
建议换成 XAMPP 1.8.2 作为本地测试服务器(这是 Joomla 官方推荐的方案),这样大家的测试平台就一样了,讨论问题时可以排除测试平台本身的影响。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!
最后修改: 2015年10月26日 10:02 由 Joomla之门.
下列用户已致谢:: e.o.m

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月26日 20:24 #11 作者: e.o.m
换成 XAMPP 1.8.2 作为本地测试服务器后安装正常了,谢谢白老大了

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月27日 15:52 #12 作者: e.o.m
换成XAMPP1.8.2能正常安装了,但是在切换到组件的管理界面的时候又有新情况了,出现了下面的大量内容:
Strict Standards: Non-static method SimplePie_Misc::fix_protocol() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 837

Strict Standards: Non-static method SimplePie_Misc::normalize_url() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 9291

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 9292

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 1546

Strict Standards: Non-static method SimplePie_Misc::get_curl_version() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 7679

Strict Standards: Non-static method SimplePie_Misc::get_curl_version() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 7691

Strict Standards: Non-static method SimplePie_Misc::xml_encoding() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 1725

Strict Standards: Non-static method SimplePie_Misc::xml_encoding() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 1744

Strict Standards: Non-static method SimplePie_Misc::change_encoding() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 1763

Strict Standards: Non-static method SimplePie_Misc::encoding() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 9415

Strict Standards: Non-static method SimplePie_Misc::encoding() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 9416

Strict Standards: Non-static method SimplePie_Parse_Date::get() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 3613

Strict Standards: Non-static method SimplePie_Parse_Date::get() should not be called statically, assuming $this from incompatible context in D:\xampp\htdocs\jt\libraries\simplepie\simplepie.php on line 3613

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月27日 16:14 #13 作者: Joomla之门
以“Strict Standards”开头的消息严格来说不算是报错。可以忽略。不过老是显示也很烦人。解决办法就是:关闭服务器的报错功能。

你尝试一下到 Joomla 后台的“全局设置 -> 服务器 -> 服务器设置” 这里,将“错误报告”这一项选择为“无”。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!
下列用户已致谢:: e.o.m

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年10月27日 20:32 #14 作者: e.o.m
恩,全局设置关闭后没有了上面的提示

登录 或者   注册一个会员帐号 来参与讨论